Autor Beitrag
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18738
Erhaltene Danke: 1634

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Do 18.07.19 08:43 
user profile icongalagher hat folgendes geschrieben Zum zitierten Posting springen:
Ja, ich habe GetIt genommen...
Damit haben schon einige Probleme gehabt. :nixweiss:

Mir ist das mit GetIt zu dumm, ich mache es lieber manuell wo es geht, dann weiß ich was da ist und es klappt auch. Zudem muss ich in GetIt alles einzeln anklicken und kann das ganze nicht in einem Package bzw. einem Installationsskript zusammenfassen...
Und gerade bei den JEDIs ist die manuelle Installation ja sehr schnell, schneller als mit GetIt, weil ich nur immer die aktuelle Version kurz auschecke ohne das ganze Paket neu zu laden.
galagher Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2305
Erhaltene Danke: 44

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter, Delphi 10.2 Tokyo Community Edition
BeitragVerfasst: Do 18.07.19 08:54 
user profile iconjaenicke hat folgendes geschrieben Zum zitierten Posting springen:
Und gerade bei den JEDIs ist die manuelle Installation ja sehr schnell, schneller als mit GetIt, weil ich nur immer die aktuelle Version kurz auschecke ohne das ganze Paket neu zu laden.
Ich würde es ja gerne manuell installieren, aber es fehlt ganz einfach das entsprechende Package, da gibt es keine Datei, die in Frage käme und damit habe ich natürlich auch keine .bpl!

Delphi lädt momentan definitiv nur die JCL.

Werde mal schauen, wo ich die JVCL herunterladen kann.

_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18738
Erhaltene Danke: 1634

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Do 18.07.19 09:50 
Auschecken kannst du beides hier:
github.com/project-jedi/jcl
github.com/project-jedi/jvcl
Nach dem Auschecken einfach die Installer ausführen (jcl\jcl\Install.bat bzw. jvcl\jvcl\Install.bat).

Bei einer neuen Version von Delphi einfach einmal pullen, dann werden die Dateien aktualisiert.

Vorher sollte alles aus GetIt deinstalliert sein.

user profile icongalagher hat folgendes geschrieben Zum zitierten Posting springen:
user profile iconjaenicke hat folgendes geschrieben Zum zitierten Posting springen:
Und gerade bei den JEDIs ist die manuelle Installation ja sehr schnell, schneller als mit GetIt, weil ich nur immer die aktuelle Version kurz auschecke ohne das ganze Paket neu zu laden.
Ich würde es ja gerne manuell installieren, aber es fehlt ganz einfach das entsprechende Package, da gibt es keine Datei, die in Frage käme und damit habe ich natürlich auch keine .bpl!
Das sind so viele Packages, dass du sie gar nicht sinnvoll manuell installieren kannst. Deshalb gibt es ja die Installer, die das übernehmen.
galagher Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2305
Erhaltene Danke: 44

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter, Delphi 10.2 Tokyo Community Edition
BeitragVerfasst: Do 18.07.19 17:46 
user profile iconjaenicke hat folgendes geschrieben Zum zitierten Posting springen:
Auschecken kannst du beides hier:
github.com/project-jedi/jcl
github.com/project-jedi/jvcl
Nach dem Auschecken einfach die Installer ausführen (jcl\jcl\Install.bat bzw. jvcl\jvcl\Install.bat).

Es widerstrebt mir, mich irgendwo anmelden zu müssen. Muss doch auch anders gehen...

_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!
Christian S.
ontopic starontopic starontopic starontopic starontopic starontopic starhalf ontopic starofftopic star
Beiträge: 20442
Erhaltene Danke: 2262

Win 10
C# (VS 2019)
BeitragVerfasst: Do 18.07.19 18:04 
Bei "Clone or download" kannst Du ohne Anmeldung eine ZIP-Datei des Repositories herunterladen.

_________________
Zwei Worte werden Dir im Leben viele Türen öffnen - "ziehen" und "drücken".

Für diesen Beitrag haben gedankt: galagher
galagher Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2305
Erhaltene Danke: 44

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter, Delphi 10.2 Tokyo Community Edition
BeitragVerfasst: Do 18.07.19 19:10 
user profile iconChristian S. hat folgendes geschrieben Zum zitierten Posting springen:
Bei "Clone or download" kannst Du ohne Anmeldung eine ZIP-Datei des Repositories herunterladen.
Danke!

Die install.bat der JCL lief problemlos.
Aber die install.bat der JVCL bemängelte "fehlende Abhängigkeiten", und man solle diese erst herstellen (wie, wird mir dabei nicht verraten).

Ich habe Delphi danach erst einmal gestartet und ja, da waren neue Pfade eingetragen. Dann Delphi wieder geschlossen und install.bat der JVCL erneut ausgeführt. Dann lief auch das!

_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18738
Erhaltene Danke: 1634

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Do 18.07.19 21:46 
Und alternativ kannst du auch TortoiseGit verwenden, dann kannst du die Daten direkt holen wie ich es hier beschrieben habe:
www.entwickler-ecke.....php?p=700257#700257
Denn wenn du dort dieses Zip herunterlädst, musst du das beim nächsten Mal wieder tun statt einfach die Dateien lokal zu aktualisieren.

Nebenbei ist Git auch als Versionsverwaltung für deine eigenen Quelltexte eine Idee, wenn du nicht schon SVN oder ähnliches nutzt.

Für diesen Beitrag haben gedankt: galagher
galagher Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2305
Erhaltene Danke: 44

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter, Delphi 10.2 Tokyo Community Edition
BeitragVerfasst: Fr 19.07.19 06:58 
Merkwürdig ist, dass die Datei jedi.inc nicht in den ZIP's enthalten ist. Man muss sie sich extra von github nachträglich hinzufügen, erst dann läuft die install.bat der JCL.

Aber jetzt ist jedenfalls alles da!

_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18738
Erhaltene Danke: 1634

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Fr 19.07.19 09:52 
Wenn du Git benutzt und ausgecheckt hättest, hätte es funktioniert. ;-)
Das ist ein Submodul und kann dann manuell per Submodule Update gezogen werden, aber das macht das install-Skript auch selbst. Aber das klappt natürlich nur, wenn es sich um ein ausgechecktes Repository handelt.
galagher Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2305
Erhaltene Danke: 44

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter, Delphi 10.2 Tokyo Community Edition
BeitragVerfasst: Fr 19.07.19 12:10 
user profile iconjaenicke hat folgendes geschrieben Zum zitierten Posting springen:
Wenn du Git benutzt und ausgecheckt hättest, hätte es funktioniert. ;-)
Ich habe eigentlich erwartet, dass es auch so funktioniert... hat es dann ja auch, nach einigem Nachbessern!

Man muss Delphi offenbar nach dem Installieren der JCL einmal starten und wieder beenden und erst danach die JVCL installieren. Oder hat das damit nichts zu tun und war nur Zufall? Aber ich habe sonst ja nichts gemacht.

Jedenfalls schreibe ich mir in einer Install.txt die einzelnen Schritte auf, damit ich das alles in einem Jahr wieder hinbekomme, ohne hier alles nachlesen und wieder Fragen stellen zu müssen!

_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18738
Erhaltene Danke: 1634

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Sa 20.07.19 05:29 
user profile icongalagher hat folgendes geschrieben Zum zitierten Posting springen:
Man muss Delphi offenbar nach dem Installieren der JCL einmal starten und wieder beenden und erst danach die JVCL installieren. Oder hat das damit nichts zu tun und war nur Zufall? Aber ich habe sonst ja nichts gemacht.
Nach der Installation von 10.3 hatte ich beide Installer der Reihe nach ausgeführt und die IDE erst danach gestartet. Dabei gab es keine Probleme.
galagher Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 2305
Erhaltene Danke: 44

Windows 7 64 Bit
Delphi XE2 Starter, Delphi 10.1 Starter, Delphi 10.2 Tokyo Community Edition
BeitragVerfasst: Mo 22.07.19 10:45 
user profile iconjaenicke hat folgendes geschrieben Zum zitierten Posting springen:
Nach der Installation von 10.3 hatte ich beide Installer der Reihe nach ausgeführt und die IDE erst danach gestartet. Dabei gab es keine Probleme.
Vielleicht hatte es ja mit dem zwischenzeitlichen Starten der IDE gar nichts zu tun, sondern es musste lediglich die install.bat der JVCL ein zweiters Mal gestartet werden, vielleicht wurden die "missing dependencies" ja dabei behoben? :nixweiss:

_________________
gedunstig war's - und fahle wornen zerschellten karsig im gestrock. oh graus, es gloomt der jabberwock - und die graisligen gulpen nurmen!
Blawen
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 614
Erhaltene Danke: 33

Win XP, Vista, 7
Delphi 5 Prof., BDS 2006 Prof. RAD Studio XE
BeitragVerfasst: Do 25.07.19 22:10 
user profile icongalagher hat folgendes geschrieben Zum zitierten Posting springen:
user profile iconjaenicke hat folgendes geschrieben Zum zitierten Posting springen:
Nach der Installation von 10.3 hatte ich beide Installer der Reihe nach ausgeführt und die IDE erst danach gestartet. Dabei gab es keine Probleme.
Vielleicht hatte es ja mit dem zwischenzeitlichen Starten der IDE gar nichts zu tun, sondern es musste lediglich die install.bat der JVCL ein zweiters Mal gestartet werden, vielleicht wurden die "missing dependencies" ja dabei behoben? :nixweiss:
Denke ich auch. In der Vergangenheit habe ich noch nie Delphi zwischenzeitlich starten müssen.

_________________
Es kompilert, wir können ausliefern.
Und es kompiliert wieder - das Update ist fertig - bitte 100 Euro ;-)