Autor Beitrag
Csharp-programmierer
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 696
Erhaltene Danke: 10

Windows 8.1
C# (VS 2013)
BeitragVerfasst: Mi 27.05.15 12:42 
Hallo Leute. Ich habe folgendes Problem:
Ich möchte ein Video einfügen. Folgende Codes habe ich probiert:

ausblenden HTML-Dokument
1:
<video src="C:\Users\Y...\Desktop\Bilder\Familie  und Freunde\MVI_1553.AVI"></video>					


oder auch so:
ausblenden HTML-Dokument
1:
<video src="file:///C:\Users\Y...\Desktop\Bilder\Familie  und Freunde\MVI_1553.AVI"></video>					


oder so:

ausblenden HTML-Dokument
1:
<img Dynsrc="file:///C:\Users\Y...\Desktop\Bilder\Familie  und Freunde\MVI_1553.AVI"></img>					


Keiner von den Codes funktioniert. Könnt ihr mit bitte weiterhelfen?
MFG :)
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18762
Erhaltene Danke: 1640

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Mi 27.05.15 12:49 
Ein Video ist kein Bild, deshalb funktioniert img nicht dafür.
Je nachdem mit welcher HTML Version und für welche Browser kannst du z.B. das video Tag oder das object oder embed Tag benutzen.

Für diesen Beitrag haben gedankt: Csharp-programmierer
Csharp-programmierer Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 696
Erhaltene Danke: 10

Windows 8.1
C# (VS 2013)
BeitragVerfasst: Mi 27.05.15 16:38 
Vielen Dank jaenicke ;)

Auf meine Win - Form Anwendung (mit C# programmiert) befindet sich ein Webbrowser, welchen ich mit der RichTextBox (das Eingabefeld für die HTML- Syntax) über das TextChanged Event verknüpft habe. Der embed Tag funktioniert zwar (der Webbrowser auf der Win - Form zeigt das Video an. Wenn ich das Programm jedoch debugge (System.Diagnostics.Process.Start(HauptPfad);) öffnet sich der normale Webbrowser (in meinem Fall: Google Chrome) wird das Video dort nicht angezeigt. Könnten Sie mir dort vielleicht weiterhelfen?

MFG :)
jfheins
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 873
Erhaltene Danke: 148

Win7
VS 2013, VS2015
BeitragVerfasst: Mi 27.05.15 18:37 
Du solltest da noch etwas mehr Info über das Video an sich liefern. Die Endung .avi deutet nämlich schon darauf hin, dass es sich um ein älteres Video handelt. Das video-Tag ist aber relativ neu und spezifiziert daher auch neuere Container-Formate.

Wie du z.B. schon anhand der Tabelle auf Wikipedia entnehmen kannst, sind einige Formate verbreitet. Der avi-Container gehört nicht dazu.

Mit gängigen Programmen (Handbrake fällt mir da ein) solltest du das Video transkodieren und neu verpacken können, um es in ein unterstütztes Format zu bringen. Für gute Kompatibilität solltest du vielleicht noch ein alternatives Format bereitstellen. Soll heißen: Mit H264 in mp4 und VP8 in WebM solltest du quasi alle Browser unterstützen.

Für diesen Beitrag haben gedankt: Csharp-programmierer
Csharp-programmierer Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 696
Erhaltene Danke: 10

Windows 8.1
C# (VS 2013)
BeitragVerfasst: Fr 29.05.15 14:50 
Vielen Danke an meine Mithelfer :):)