Autor Beitrag
Fabian W.
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 1766

Win 7
D7 PE
BeitragVerfasst: Di 07.02.06 15:20 
Ich merk' 'grad: Der Fehler tritt immer nur auf, wenn ich eine Playlist schon offen habe (seit dem letzten start). In den Dateideteils steht aber der Pfad + Dateiname und die Warnung, "die Datei existiert nischt..."
ich hoffe es hilft dir
UGrohne
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Veteran
Beiträge: 5502
Erhaltene Danke: 220

Windows 8 , Server 2012
D7 Pro, VS.NET 2012 (C#)
BeitragVerfasst: Di 07.02.06 18:11 
user profile iconGausi hat folgendes geschrieben:
Und nur dass ich das richtig verstehe...Als du später mal ein PopUpMenu geöfnet hast (also Rechtsklick innerhalb einer der Listendarstellung), da standen in diesem Menu die Details eines Liedes? Oder öffnete sich "nur" das Dateidetails-Fenster mit evtl. unsinnigen Angaben?

Ne, die Dateidetails oeffneten sich direkt nach dem Import aus Winamp und dann noch einmal als ich auf den Reiter Suchen klickte. Danach aber seltsamerweise nicht mehr. Und es standen unsinnige Angaben drin, im Titel glaub N/A und sonst keine Daten
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Di 07.02.06 18:30 
@Fabian: Da hab ich jetzt nicht verstanden. Wann tritt der Fehler auf? Wenn du die Playliste vom letzten Mal durch eine andere ersetzt, oder wenn beim Start die Playlist vom letzten Mal geladen wird? Und ist der Fehler reproduzierbar, oder tritt er nur manchmal auf? Falls ja, wie kann man ihn provozieren?

@Uwe: Das ist mir später auch eingefallen, dass du wahrscheinlich das gemeint hast ;-) Das ist nicht wirklich ein Fehler. In diesem Fenster erscheinen immer die Details des ausgeählten Items. Wenn keins ausgewählt ist, gibts die N/A-Anzeige. Dass das Fenster mit diesen Angaben unter gewissen Umständen extra dafür angezeigt wird, ist natürlich unschön. Da muss ich die Überprüfung etwas anpassen.
Ein Geisterfile spukt da aber nicht rum ;-)

_________________
Oel ngati kameie.
Fabian W.
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 1766

Win 7
D7 PE
BeitragVerfasst: Mi 08.02.06 13:55 
wenn beim Start die Playlist vom letzten Mal geladen wird. Bei mir kommt gleich nach dem start auf ein Dateidetailsfenster, indem aber noch alle angaben korrekt sind. erst wenn ich die playlist spielen will kommt auch da die o.g. Meldung.
Reproduzieren is einfach: Playlist machen über Dateien hinzufügen, player schließen, wieder öffnen, auf play drücken...
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Mi 08.02.06 14:10 
Den Fehler kann ich bei mir nicht nachvollziehen :gruebel:. Ist die Playlist-Datei (nemp.m3u) denn gültig, d.h. kann sie in einem anderen Player geladen werden?
Oder funktioniert es, wenn du die Datei manuell lädst?

Öffne ggf. die Datei bitte mal im Editor und überprüfe, ob die Pfadangaben da stimmen...

_________________
Oel ngati kameie.
Fabian W.
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 1766

Win 7
D7 PE
BeitragVerfasst: Mi 08.02.06 14:17 
Und ich frag mich schon wo der die Liste speichert... In dem Ordner gibt es kein PLaylist. Nur 2 DLLs, die exe, 1rtf und 2txt... :shock:
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Mi 08.02.06 14:21 
Ah..kann sein, dass du die XP-Version hast: dann ist der Speicherort "Dokumente und Einstellungen\{user}\Anwendungsdaten\Gausi\Nemp\". Ansonsten dürfte der beim Neustart gar nichts anzeigen. Da müsste eine NempXP.ini, NempXP.m3u und ein NempXP.gmp liegen. Die beiden ersten sind Standard-Formate, das letzte ein Spezialformat von mir.

_________________
Oel ngati kameie.
Stübi
ontopic starontopic starontopic starontopic starhalf ontopic starofftopic starofftopic starofftopic star
Beiträge: 331

Win XP, Win 2000, Win ME
D5 Ent, D7 Prof, D2005 PE, C#
BeitragVerfasst: Mi 08.02.06 14:45 
Kann ich, um die Headsetfunktion zu nutzen einfach eine weitere Soundkarte anschliessen und dann sollte es gehen?

gruss Stübi

_________________
Neun von zehn Stimmen in meinen Kopf sagen, dass ich nicht verrückt sei. Die zehnte summt die Tetrismelodie.
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Mi 08.02.06 14:48 
Ja, dann sollte es gehen. Getestet hab ichs bei mir (OnBoard-Karte + Audigy2) sowie bei meinem Bruder am Laptop (Laptopkarte + USB-Gitarren-Aufnahme-Irgendwas). Aber bitte nicht anmäkeln, dass man dann für beide Ausgaben dieselbe Karte benutzen kann - das steht auf der ToDo-Liste ;-)

_________________
Oel ngati kameie.
Fabian W.
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 1766

Win 7
D7 PE
BeitragVerfasst: Mi 08.02.06 15:15 
In der datei findet sich ein relativer pfad:
ausblenden Quelltext
1:
..\..\..\Eigene Dateien\Eigene Musik\M1.wma					

Kann es sein, dass Nemp damit Probleme hat? Mediaplayer spielt sie auf jeden fall einwandfrei...
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Mi 08.02.06 16:52 
Doch, Nemp kommt damit klar - schließlich speichert er das ja auch so ab ;-)

Der Fehler ist aber lokalisiert und korrigiert. Hatte bei der Laderoutine der Playlisten vergessen, dass aktuelle Verzeichnis auf das Verzeichnis der m3u-Datei zu setzen - somit lieferte ExpandFilename(aRelativePath); natürlich falsche Werte.
Es sei denn, das Verzeichnis stimmt überein (d.h. die m3u ist im Programmverzeichnis) oder die m3u-Datei liegt auf einer anderen Partition/Platte wie die mp3s. Da ich auf "C:\" praktisch keinerlei Daten habe, konnte ich den Fehler zunächst nicht reproduzieren. Beim nächsten Update ist der weg ;-)

Das manuelle Laden der automatisch gespeicherten Playlist sollte aber demnach funktionieren...

_________________
Oel ngati kameie.
Fabian W.
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 1766

Win 7
D7 PE
BeitragVerfasst: Mi 08.02.06 16:57 
ein update proggie fände ich sinnvoll, natürlich nur wenn du das projekt weiter fortführst.
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Mi 08.02.06 17:14 
Zur Zeit stehen noch zwei (kleine) Dinge auf meiner Liste, wobei ich bei beiden noch nicht sicher bin, ob und wenn ja wie ich sie realisiere.

Wenn ich mir darüber im Klaren bin, lad ich das hoch.

Weiterentwickelt wird das aber bestimmt. Hab da noch so ein paar Ideen...leider dürfte wenigstens eine davon nicht wirklich realisierbar sein :-(

_________________
Oel ngati kameie.
Fabian W.
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 1766

Win 7
D7 PE
BeitragVerfasst: Mi 08.02.06 17:17 
warum welche denn?
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Mi 08.02.06 17:30 
Z.B.: "Finde einen Titel, der zum gerade abgespielten passt".

Beispiel: Es läuft "Haddaway - Life", gefunden wird "Culture Beat - Mr.Vain". Klar, was ich meine?

_________________
Oel ngati kameie.
Fabian W.
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 1766

Win 7
D7 PE
BeitragVerfasst: Mi 08.02.06 17:53 
ich weiß nicht wie du suchst, aber ich würde da so machen:
1) Natürlich nur im gleichen Genre suchen
2) Wenn Lyrics gefunden werden die Häufigkeuit von Hauptwörtern ermitteln und mit anderen Titeln und deren Lyrik vergleichen
3) Bass- und sonstige Werte (zB die von der Visualisierung) miteinander vergleichen.
4) Album Interpret insofern berücksichtigen, dass sie bei der suche vorgezogen werden
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Mi 08.02.06 18:07 
Punkt 1 scheidet aus, weil
a. das Genre in der Regel meist nicht oder falsch gesetzt ist
b. verschiedene Genres durchaus zueinander passen (guck dir mal die Genreliste auf id3.org an)
c. durchaus einzelne Titel aus sehr unterschiedlichen Genres vom Rhytmhmus her sehr ähnlich sein können

Punkt 2 scheidet aus weil
a. die Lyrics sehr selten sind
b. der Text eines Liedes praktisch nichts über seinen Klang aussagt
c. einige Stücke praktisch keinen Text haben (abgesehen von Pseudo-gebrabbel wie "Hyper Hyper" :lol:)

Punkt 4. ließe sich natürlich einbauen.

Punkt 3. Gut vergleichen wir den Sound. Angenommen, ich habe diese Werte (dürfte mit der bass.dll gehen). Was bedeutet es, dass Lied A ähnlich wie Lied B klingt? Was ist Rhtyhmus, wie finde ich ihn heraus, wie speichere ich ihn ab und wie finde ich dann ähnliche? Wie erkenne ich einen Walzer, oder einen ChaChaCha? Die reine Beat-per-Minute-Zahl ist relativ aussageschwach (abgesehen davon, dass ich auch die nicht einfach ermitteln kann, da die Bässe ja ab und zu aussetzen für melodische Phasen). Wie unterschiede ich die Bässe aus einem Techno-Stück von denen in einem Metal-Stück? Wenn du da gute Ideen hast, schick mir den Quellcode :mrgreen:

_________________
Oel ngati kameie.
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8433
Erhaltene Danke: 440

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.2 CE
BeitragVerfasst: Do 09.02.06 15:54 
So, Version 2.1 mit kleinen Änderungen ist jetzt online. War lauter Kleinkram - eine Änderung der Versionsnummer dafür halte ich bei der gegenwärtigen Verbreitung nicht für nötig ;-)

  • Fehler: Laden der Playliste funktionierte unter gewissen Umständen nicht richtig (die relativen Pfade wurden falsch komplettiert)
  • Neue Funktion: Buffergröße einstellbar (in ms). Damit sollte ein Stottern der Wiedergabe seltener auftreten (wenn man die Größe entsprechend heraufgesetzt hat).
  • Anderung: Eigener Dialog für die Player-Einstellungen
  • Änderung: Funktion "in Headset abspielen" jetzt auch in der Playliste deaktiviert, wenn nur eine Soundkarte gefunden wurde
  • Änderung: Das aktuell abgespielte Fle wird jetzt blau (bzw. grün/silber..) umrahmt statt blau hinterlegt - damit bleibt die Lesbarkeit erhalten
  • Änderung: Anzeige "N/A" im Detailfenster sollte jetzt seltener kommen
  • Änderung: Lautstärkeregler setzt die Lautstärke jetzt nur lokal, nicht global fürs Device
  • Handling: Bei der Kartenausahl ist es nun nicht mehr möglich, für beide Ausgaben dieselbe Karte zu benutzen
  • Handling: Faden innerhalb eines Titels per STRG-Cursor entfernt (hat eh nur bedingt funktioniert) - damit dürfte die Lautstärke-Regelung am Laptop wieder funktionieren.
  • Funktion entfernt: Im Detailfenster gabs noch nen Play-Button, der eine Datei mit der Standardanwendung öffnete. War ein Relikt aus der Zeit, in der noch kein Player integriert war.
  • Mini-Fehler: Unter gewissen Umständen wurde die Balance um 1% nach links verschoben

_________________
Oel ngati kameie.
Fabian W.
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 1766

Win 7
D7 PE
BeitragVerfasst: Do 09.02.06 17:13 
Ich dachte mehr so an durchschnittliche bzw auffällige basswerte...

warn ja auch nur vorschläge wie hast du denn gesucht?
UGrohne
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Veteran
Beiträge: 5502
Erhaltene Danke: 220

Windows 8 , Server 2012
D7 Pro, VS.NET 2012 (C#)
BeitragVerfasst: Fr 10.02.06 04:08 
So, hab mal wieder getestet:
  • Die Hervorhebung der markierten Dateien ist irgendwie immer noch in derselben Farbe, ich glaube das hast Du falsch verstanden ;-)
  • Es wäre glaube ich geschickt, wenn bei einem Rechtsklick in die Liste auch markiert wird, also wenn ich auf das 3. mit der rechten Maustaste klicke, dieses auch gleich markiert wird und nicht das erste markiert bleibt
  • Beim Start und manchmal bei Funktionen (z.B. einmal beim "Duplikate und tote Files entfernen") kommt der Eigenschaftsdialog des gerade markierten Liedes wieder hoch. Ich kann aber nicht nachvollziehen wann
  • Meine globale Lautstärkeregelung wird immer noch geklaut :(
  • Das Einblenden der Toolbar während der Suche stört ein wenig, vielleicht könntest Du diese die ganze Zeit einblenden und evtl. noch ein paar Buttons reinmachen, damits net stört? Dachte mir erst am Anfang was da kurz für ein Teil erscheint *g*
  • Das Drag&Drop-Verhalten ist etwas seltsam. Ich kann von der Playliste auf die Mittelkonsole ziehen aber es passiert nichts, genauso wie von der Medialist.
  • ... ich glaube das wars erstmal ;-)