Autor Beitrag
juelin
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 40

Win XP, Linux
D7 K3
BeitragVerfasst: Mo 08.07.19 10:26 
so,
jetzt habe ich mal nur ein Mobile Firemonkey-Anwendung - Delphi Projekt erzeugt.
In die Handy-Oberfläche zwei TEDIT eingefügt.
KEIN einzigen Befehl geschrieben und NICHTS an den Eigenschaften und Projekt geändert (alles Standard).
Dann das Projekt Compeliert und auf das Handy geladen.
Oberes Edit angeklickt, was eingegeben und ENTER gedrückt.
Dann unteres Edit angeklickt und bei der Eingabe des ersten Zeichens
bekomme ich Segmentation fault (11).
Siehe Anhänge.
Kann bei den Standard-Einstellungen (Form, Edit) was nicht stimmen?
Jetzt seid Ihr dran.
Gruß Jürgen
Ich habe:
Windows 10
Delphi Rad-Studio XE5
Handy Sony Xperia 10
Einloggen, um Attachments anzusehen!
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18731
Erhaltene Danke: 1631

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Mi 10.07.19 08:03 
Leider habe ich kein XE5, so dass ich es nicht ausprobieren kann. Im Stacktrace aus dem Crosspost ist auch nichts weiter zu sehen.

Bei mobiler Entwicklung ist es schwierig, wenn man auf älteren Versionen von Delphi bleibt. Eigentlich funktioniert das nur sinnvoll, wenn man immer eine relativ aktuelle Version nutzt. Ich schlage mal vor, dass du das gleiche einmal mit der aktuellen Community Edition testest um zu schauen, ob es dort vielleicht schon behoben ist.
Wenn nicht, kannst du ein Ticket dafür aufmachen.

Zum Debuggen:
Was passiert denn, wenn du den Inhalt deines OnKeyUp auskommentierst? Bzw. kommst du dort an einem Haltepunkt vor dem Fehler an und bekommst den Fehler auch beim zeilenweise Debuggen?
juelin Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 40

Win XP, Linux
D7 K3
BeitragVerfasst: Do 11.07.19 12:46 
Habe es probiert auf
Delphi 10.3 Community Edition.
Bekomme aber den Fehler:
Performing Streamed install.
Gruß
Jürgen
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18731
Erhaltene Danke: 1631

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Do 11.07.19 12:58 
Dann wird das Projekt noch von XE5 installiert sein. Delphi 10.3 kann das dann nicht deinstallieren, sprich das muss dann manuell passieren.
Oder hattest du ein neues Projekt angelegt?
juelin Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 40

Win XP, Linux
D7 K3
BeitragVerfasst: Do 11.07.19 16:59 
ja danke,
hat geholfen.
Jetzt noch eine Frage.
Wo im Handy überall muss man Deleten,
damit ein Projekt auch wirklich raus ist?
Welche Verzeichnisse?
Habe APP gestoppt und deinstalliert.
hat aber nix geholfen.
Danke und Gruß
Jürgen
jaenicke
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 18731
Erhaltene Danke: 1631

W10 x64 (Chrome, IE11)
Delphi 10.2 Ent, Oxygene, C# (VS 2015), JS/HTML, Java (NB), PHP, Lazarus
BeitragVerfasst: Do 11.07.19 21:02 
Es sollte reichen vor (!) der Deinstallation den Cache und die Daten der App zu löschen und diese dann erst zu deinstallieren. Dann sollte das meiste weg sein.

Es gibt dafür auch Tools wie dieses:
play.google.com/stor...evouninstallermobile
Die kenne ich aber nicht, deshalb kann ich leider keins besonders empfehlen.


Zuletzt bearbeitet von jaenicke am Fr 12.07.19 12:02, insgesamt 1-mal bearbeitet
juelin Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starontopic star
Beiträge: 40

Win XP, Linux
D7 K3
BeitragVerfasst: Fr 12.07.19 10:08 
danke für die Hilfe.