Autor Beitrag
Gausi
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8473
Erhaltene Danke: 447

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.3 CE
BeitragVerfasst: Fr 19.04.19 16:52 
Bei meinem mp3-Player ist (mal wieder) die Lyric-Suche kaputt. Zum einen wurde der Quelltext der Seite geändert, aus dem ich die Liedtexte rauskopiere, zum anderen wurde die Seite komplett von http auf https umgestellt. Jetzt muss ich gucken, wie ich da am besten Zugriff kriege. :gruebel:

Möglichkeit 1: Weiter mit Indy, einem IOHandler, und die OpenSSL-Libraries mitliefern. Findet man ja genug Code-Beispiele, und habe ich auch schon mal woanders so genutzt.

Möglichkeit 2: THttpClient aus den neuen Delphi-Versionen nutzen (System.Net.URLClient, System.Net.HttpClient). Dabei werden wohl die bei Windows mitgelieferten Bibliotheken dafür genutzt. Macht ggf. unter nicht voll gepatchten Windows-7 Probleme, aber das bekommt man in den Griff, wenn man explizit die neueren Protokolle setzt, was unter W7 per Default nicht gemacht wird, also
ausblenden Delphi-Quelltext
1:
HttpClient.SecureProtocols := [THTTPSecureProtocol.TLS12, THTTPSecureProtocol.TLS11];					


Da ich absolut unerfahren auf dem Gebiet bin - gibt es da irgendwo noch versteckte Fallstricke? Oder was sind die Vor- und Nachteile der beiden Varianten?

So wie ich das sehe, muss ich bei (1) zusätzliche Dateien ausliefern, und muss mich ggf. um das patchen kümmern, wenn es da Sicherheitsprobleme gibt. Bei (2) schiebe ich das komplett auf das Betriebssystem, muss dann aber mindestens Windows 7 (?) voraussetzen. Beides sind ja keine besonders dicken Einschränkungen - ich würde aktuell (2) vorziehen. Was meint ihr?

_________________
We are, we were and will not be.
trm
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 491
Erhaltene Danke: 19

Windows 7x64
Delphi 7
BeitragVerfasst: So 31.05.20 15:58 
Hallo Gausi,

hast Du einmal versucht das aktuell zu testen?

Ich habe mir deinen Update-Code in ein kleines eigenes Tool eingebaut, nun bekomme ich immer einen Fehler, wenn ich auf meine Seite zugreifen möchte.

Als Fehler wird ERROR_WINHTTP_SECURE_FAILURE (Error Code 12175) erzeugt, wobei ich auch nicht genau dahinter komme, warum.

LG Mathias

_________________
In Erfurt gibt es eine Pension, in der es gemütlich ist, Google einfach nach Pension Fiege ;)
Gausi Threadstarter
ontopic starontopic starontopic starontopic starontopic starontopic starofftopic starofftopic star
Beiträge: 8473
Erhaltene Danke: 447

Windows 7, Windows 10
D7 PE, Delphi XE3 Prof, Delphi 10.3 CE
BeitragVerfasst: So 31.05.20 16:48 
In der Delphipraxis wurde mir im Crosspost zu (2) geraten, und das funktioniert soweit einwandfrei.

Wenn ich deinen Fehlercode google, kommen Hinweise auf Probleme mit dem Zertifikat. Hast du in der Richtung mal geschaut, ob alles in Ordnung ist?

btw.: Falls du den Update-Code aus meinem Player meinst - da spielt das eh noch keine Rolle. Ich muss da wirklich mal die Sicherheit erhöhen - bisher habe ich dort nur http (ohne s).

_________________
We are, we were and will not be.
trm
ontopic starontopic starontopic starontopic starontopic starontopic starontopic starofftopic star
Beiträge: 491
Erhaltene Danke: 19

Windows 7x64
Delphi 7
BeitragVerfasst: So 31.05.20 17:03 
user profile iconGausi hat folgendes geschrieben Zum zitierten Posting springen:
In der Delphipraxis wurde mir im Crosspost zu (2) geraten, und das funktioniert soweit einwandfrei.


Danke, habe ich gefunden. Hilft mir leider nicht weiter, weil ich die Fehlermeldung nicht verstehe.


user profile iconGausi hat folgendes geschrieben Zum zitierten Posting springen:
Wenn ich deinen Fehlercode google, kommen Hinweise auf Probleme mit dem Zertifikat. Hast du in der Richtung mal geschaut, ob alles in Ordnung ist?


Im Browser ist alles in Ordnung, im Programm leider der entsprechende Fehler.


user profile iconGausi hat folgendes geschrieben Zum zitierten Posting springen:
btw.: Falls du den Update-Code aus meinem Player meinst - da spielt das eh noch keine Rolle. Ich muss da wirklich mal die Sicherheit erhöhen - bisher habe ich dort nur http (ohne s).


Ja, das meinte ich. HTTPS wird ja eigentlich unterstützt - bis vor 4 Wochen etwa klappte noch alles. Heute habe ich mich wieder dran gesetzt und die Fehlermeldung stört das Tool.

Danke für Deine Hilfe :-)
LG und ein schönes langes WE.

_________________
In Erfurt gibt es eine Pension, in der es gemütlich ist, Google einfach nach Pension Fiege ;)